Installing Open Foris Geospatial Toolkit

From Open Foris Wiki

Jump to: navigation, search
Line 43: Line 43:
#and '''update''' to the latest version using command <pre>oft-update.bash</pre>  
#and '''update''' to the latest version using command <pre>oft-update.bash</pre>  
#You can also '''uninstall''' all the tools. To do that, enter the command:<pre>oft-uninstall.bash</pre>
#You can also '''uninstall''' all the tools. To do that, enter the command:<pre>oft-uninstall.bash</pre>
 +
 +
-----
 +
 +
 +
==To-Do List==
 +
 +
#'''Test Cygwin'''
 +
[http://www.cygwin.com/ Cygwin] projects provide a Linux terminal in Windows.
 +
 +
To compile the Open Foris you need to compile GDAL manually:
 +
 +
Download from the [http://trac.osgeo.org/gdal/wiki/DownloadSource  gdal official repository] (e.g gdal-1.8.1.tar.gz) and install using the following commands commands:
 +
<pre>
 +
cd ~
 +
tar -xvwzf gdal-1.8.1.tar.gz
 +
cd gdal-1.8.1
 +
./configure
 +
make
 +
make install
 +
</pre>
 +
 +
By the cygwin setup.exe select gsl library (http://www.gnu.org/software/gsl/): gsl , gsl-app , gsl-devel , gsl-doc
 +
and install.
 +
 +
At this point you can install OpenForis:
 +
<pre>wget http://foris.fao.org/static/geospatialtoolkit/
releases/OpenForisToolkit.run</pre>
 +
<pre>chmod u+x OpenForisToolkit.run</pre>
 +
<pre>./OpenForisToolkit.run</pre>
 +
----
 +
----
----

Revision as of 13:26, 9 July 2013

Personal tools