Hello Everyone, I had set up PostgreSQL to store the data in my old Openforis Collect. Since the new update/install of the Collect I couldn't find any of my work in Collect interface that was previously in PostgreSQL. As new Collect becomes entirely different than the previous one, could anyone suggest me how to set up PostgreSQL to store my database in the latest version?

Regards Milan

asked 27 Apr, 19:27

dhunganamilan's gravatar image

dhunganamilan
454
accept rate: 0%


Hi Milan,
In the Collect installation folder there is a file called collect.properties. Please modify it and set the correct parameters to access your database.
Many thanks,
Open Foris Team

permanent link

answered 27 Apr, 19:53

OF%20Collect's gravatar image

OF Collect ♦♦
1.0k4
accept rate: 14%

Hi Milan,

this should work. Go to this folder: C:\Users\USERNAME\OpenForis\Collect and take a safety copy of the original file collect.properties

Then change the settings to be as follows:


collect.http_port=8380

collect.db.jndiName=jdbc/collectDs

collect.db.driverClassName=org.postgresql.Driver

collect.db.url=jdbc:postgresql://localhost:5432/collect

collect.db.username=collect

collect.db.password=collect123

collect.db.initialSize=5

collect.db.maxActive=20

collect.db.maxIdle=5


Then start Collect with the Launcher.

Regards, Lauri

permanent link

answered 28 Apr, 03:51

LauriV's gravatar image

LauriV
46225
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×162
×24

question asked: 27 Apr, 19:27

question was seen: 75 times

last updated: 28 Apr, 03:51

Open Foris Support - 2014