Dear colleagues,

It seems I have some sync problems between CE and GEE Playground. It works for a couple of plots, but then it just keeps the coordinates from the last plot and it does not updates it.

I copy the error log for your reference.

Thank you beforehand.

Andres.

ERROR 2018-04-09 03:03:48,992 [Opening GEE Playground SimplePlacemarkObject [coord=-15.24694607080144,49.67081129495903, nextPlacemarkId=unknown, placemarkId=null, points=null, region=null, shape=null, samplePointOutlined=null, elevation=0, slope=0, aspect=0, extraInfo=null, valuesByColumn=null, extraColumns=null, idColumns=null, originalLatitude=null, originalLongitude=null, kmlPolygon=null]] org.openforis.collect.earth.app.service.CodeEditorHandlerThread: Error when opening Earth Engine browser window org.openqa.selenium.ElementNotVisibleException: element not visible (Session info: chrome=65.0.3325.181) (Driver info: chromedriver=2.35.528161 (5b82f2d2aae0ca24b877009200ced9065a772e73),platform=Windows NT 6.1.7601 SP1 x86_64) (WARNING: The server did not provide any stacktrace information) Command duration or timeout: 0 milliseconds Build info: version: '3.10.0', revision: '176b4a9', time: '2018-03-02T19:03:16.397Z' System info: host: 'ABEPC', ip: '192.168.88.103', os.name: 'Windows 7', os.arch: 'amd64', os.version: '6.1', java.version: '1.8.0_121' Driver info: org.openqa.selenium.chrome.ChromeDriver Capabilities {acceptInsecureCerts: false, acceptSslCerts: false, applicationCacheEnabled: false, browserConnectionEnabled: false, browserName: chrome, chrome: {chromedriverVersion: 2.35.528161 (5b82f2d2aae0ca..., userDataDir: C:\Users\ABE\AppData\Local...}, cssSelectorsEnabled: true, databaseEnabled: false, handlesAlerts: true, hasTouchScreen: false, javascriptEnabled: true, locationContextEnabled: true, mobileEmulationEnabled: false, nativeEvents: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: XP, platformName: XP, rotatable: false, setWindowRect: true, takesHeapSnapshot: true, takesScreenshot: true, unexpectedAlertBehaviour: , unhandledPromptBehavior: , version: 65.0.3325.181, webStorageEnabled: true} Session ID: 23947b3a48b2cb6e97e2343494df0945 at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_121] at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_121] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.8.0_121] at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.8.0_121] at org.openqa.selenium.remote.ErrorHandler.createThrowable(ErrorHandler.java:214) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.ErrorHandler.throwIfResponseFailed(ErrorHandler.java:166) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.http.JsonHttpResponseCodec.reconstructValue(JsonHttpResponseCodec.java:40) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.http.AbstractHttpResponseCodec.decode(AbstractHttpResponseCodec.java:80) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.http.AbstractHttpResponseCodec.decode(AbstractHttpResponseCodec.java:44) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:160) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.service.DriverCommandExecutor.execute(DriverCommandExecutor.java:83) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:601) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.RemoteWebElement.execute(RemoteWebElement.java:279) ~[selenium-remote-driver-3.10.0.jar:?] at org.openqa.selenium.remote.RemoteWebElement.sendKeys(RemoteWebElement.java:100) ~[selenium-remote-driver-3.10.0.jar:?] at org.openforis.collect.earth.app.service.CodeEditorHandlerThread.runScript(CodeEditorHandlerThread.java:114) ~[CollectEarth.jar:?] at org.openforis.collect.earth.app.service.CodeEditorHandlerThread$1.run(CodeEditorHandlerThread.java:280) [CollectEarth.jar:?]

asked 09 Apr, 02:13

abespejo's gravatar image

abespejo
153
accept rate: 0%


Hola Andres,

I think the key problem is "org.openqa.selenium.ElementNotVisibleException: element not visible"

This means that the Code Editor "script editor" window is not visible, thus Collect Earth cannot write to it and cannot run the script.

Make sure that the frame with the map is not totally maximized so that at least a bit of the top frames are visible , like this :

alt text

permanent link

answered 09 Apr, 11:31

collectearth's gravatar image

collectearth ♦
61515
accept rate: 16%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×249
×155

question asked: 09 Apr, 02:13

question was seen: 116 times

last updated: 09 Apr, 11:31