Dear Sir/Madam, I would like to inform you that I am using openforis collect 4.0.8. I am trying to enter data by mulita users by creating Users and Groups. But, I wanted to allow to appear recorded data with respective users locations only. Such as user1 lies in a location: province1 only allows to enter data and appear province1 only. How we can be set the Record attribute/code list filter. I have set Attribute/code list name “province” then code 1 for user1 as Handbook instruction. But it doesn’t work to set the specific record province1 only. Kindly suggest fixing this.

Thank you, Sincerely, Kedar

asked 20 Jan, 11:47

kedarkus's gravatar image

kedarkus
111
accept rate: 0%


Dear Kedar,
Unfortunately with the version 4 of Collect this feature is not working anymore as expected, but it will work from version 4.0.10+.

Meanwhile, please follow these steps:

  • in the Survey Designer define a code list with all the provinces, with code like for example province_1, province_2, and so on
  • define a code attribute "province" and mark it as "qualifier", using the flag in the Survey Designer attribute editor
  • define user groups and for every group assign a value among the qualifier values (for example one group will have value "province_1", another one "province_2" and so on)
  • each user with only data_entry role, belonging to a group for which a value for the qualifier has been specified, will not be allowed to edit a "qualified" field (the attribute "province") and it's value will come from the specified one in the group; also in the records list, only records belonging to the same group will be visible;

Thanks a lot,
Open Foris Team

permanent link

answered 21 Jan, 00:09

OF%20Collect's gravatar image

OF Collect ♦♦
3.6k18
accept rate: 23%

Dear Open Foris Team,

Thank you very much for providing useful instruction to set the specific record based on the user's name. Based on the instruction I have tried it and now having to face the following errors: HTTP ERROR 404 Not Found URI: /collect/perform_login STATUS: 404 MESSAGE: Not Found SERVLET: dispatcher

Please suggest how do I fix the problems. I have uninstalled the openforis and reinstinalled it by the newer version but still having the same error.

Kind regards,

Kedar

permanent link

answered 22 Jan, 11:40

kedarkus's gravatar image

kedarkus
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×411

question asked: 20 Jan, 11:47

question was seen: 263 times

last updated: 22 Jan, 11:40