Hello, I cannot launch Collect Earth from the launcher. When trying from terminal I get the following error:

./java/bin/java -jar CollectEarth.jar

[very long output ...]

SEVERE: The server could not start java.lang.NullPointerException at org.openforis.collect.earth.app.desktop.ServerController.startServer(ServerController.java:253) at org.openforis.collect.earth.app.desktop.EarthApp.serverStartAndOpenGe(EarthApp.java:446) at org.openforis.collect.earth.app.desktop.EarthApp.startServer(EarthApp.java:325) at org.openforis.collect.earth.app.desktop.EarthApp.startCollectEarth(EarthApp.java:312) at org.openforis.collect.earth.app.desktop.EarthApp.handleMacStartup(EarthApp.java:176) at org.openforis.collect.earth.app.desktop.EarthApp.main(EarthApp.java:97)

asked 23 Feb, 17:26

cecilia's gravatar image

cecilia
111
accept rate: 0%


Dear Cecilia,

We have not been able to reproduce this issue in our Catalina testing machine ( or in any other versions ). Have you installed the latest version of the software? Is there anything in your computer that might prevent the software from running normally (like a very restrictive antivirus )?

The latest version of Collect Earth is 1.12.8 (as of 24/2/2021). The easiest way for you would be to download the installer from our website LINK.

alt text

Let us know if this fixes your issue!

permanent link

answered 24 Feb, 13:12

collectearth's gravatar image

collectearth ♦
98215
accept rate: 17%

Hello,

I have unistalled and re-installed Collect Earth from your link. No error appears during installation. The launcher starts (i.e. the logo of Collect Earth appears), but disappears after a few seconds and the program does not start.

Could it help to update to the latest version operating system?

Thank you.

permanent link

answered 24 Feb, 14:33

cecilia's gravatar image

cecilia
111
accept rate: 0%

I also have the same issue on my MacBook, but for some reason it is working on my iMac. I have also tried updating the operating system and used the updated software. Any fix?

permanent link

answered 03 Mar, 10:58

geog3605's gravatar image

geog3605
111
accept rate: 0%

It seems that Collect Earth is not being allowed to write the necessary files to this folder : Users/YOUR_USERNAME/Library/Application Support/CollectEarth

This causes the server to not be able to run and then CE fails...

Most likely you have some sort of antivirus or security application/settings that is preventing CE to write to the filesystem, in that case please add CE to the whitelisted applications ( probably you need to add java too Users/YOUR_USERNAME/OpenForis/CollectEarth/java/bin/java and Users/YOUR_USERNAME/OpenForis/CollectEarth/CollectEarth-launcher)

permanent link

answered 03 Mar, 11:16

Open%20Foris's gravatar image

Open Foris ♦♦
7235614
accept rate: 9%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×248

question asked: 23 Feb, 17:26

question was seen: 220 times

last updated: 03 Mar, 11:16