Saiku will not launch. The error message states:

The SAiku Server is not configured. Set-up the path to the folder where Saiku Server is installed in the Tools> Properties>Advanced tab. The JAVA_HOME environment variable is not configured. JAVA_HOME must oint to the root folder of a valid JDK.

The Saiku path is currently pointed to C:\Users\bafriesen\Documents\saiku-server_2.6/ and if it is changed to the recommended setting of C:\OpenForis\CollectEarth\saiku-server_2.6 it doesn't help. I'm wondering if this has something to do with the set-java.bat not running but am not sure what the fix is.

asked 27 Oct '15, 10:43

Ly2's gravatar image

Ly2
11112
accept rate: 0%


Hi Bev,

Was it working before? Did you do any changes of anything you can recall?

The reasons for the Saiku server not running can be two:

  1. The COLLECT_EARTH_JRE_HOME environment variable should be set to the path where the Java Runtime Environment (JRE) that comes in the installation package of Collect Earth is. Usually the path should be in Windows C:/OpenForis/CollectEarth/java but check in case you chose to install Collect Earth in a different folder. It should look like this in your account environment variables: alt text
  2. You are using an older version of Collect Earth (previous to version 1.1), but this is unlikely, that uses the Windows environment variable JAVA_HOME to open Saiku. In this case proceed to set the new environment variable JAVA_HOME to the same folder as the COLLECT_EATH_JRE_HOME ( C:/OpenForis/CollectEarth/java )

If this doesn't help please copy the last 100 or so lines of the log file ( in Collect Earth, Help menu->Open Application log file ) and send them through the forum !

permanent link

answered 27 Oct '15, 11:08

collectearth's gravatar image

collectearth ♦
51014
accept rate: 18%

edited 27 Oct '15, 11:10

We were able to run SAIKU manually by clicking on the set-java.bat file, then opening a Chrome window and pasting in '127.0.0.1:8181'. The data were all there, so this was a fine work around. When we tried to start Saiku from the CE menu after this, the same error message persisted.

The CE version is the newest one. Saiku didn't run ever on about 30 laptops and no changes were made. I didn't see where it was installed and will have to check on the location of the COLLECT_EARTH_JRE_HOME environment variable.

permanent link

answered 27 Oct '15, 11:41

Ly2's gravatar image

Ly2
11112
accept rate: 0%

Hi Bev!

then the windows environment variables were set fine... Are you using Windows 10? There was an issue last week with Windows 10 and browser windows not opening....

Anyway please send me the log files so I can investigate further!

permanent link

answered 27 Oct '15, 11:44

collectearth's gravatar image

collectearth ♦
51014
accept rate: 18%

We now have a solution based on your suggestion. This worked.

Go to My Computer --> Control Panel --> Systems --> Advanced System Setting --> Environment Variables Add a new variable in the User variable "JAVA_HOME" with path to C:/OpenForis/CollectEarth/java/bin

Save it. Run the application again. Then Saiku works.

permanent link

answered 28 Oct '15, 04:07

Ly2's gravatar image

Ly2
11112
accept rate: 0%

Slight correction...the path was c:\OpenForis\CollectEarth\java\bin

(28 Oct '15, 04:10) Ly2 Ly2's gravatar image

Thank you for reporting and debugging the problem!

This issue was provoked because of new Collect Earth installers do not set the JAVA_HOME environment variable anymore but they still require it to be set!

Starting with Collect Earth 1.2.7 the issue is fixed, you can proceed to update your Collect Earth in order to fix the issue (Help->Check for new versions of Collect Earth )

Please report any other issues you might be having!

permanent link

answered 01 Nov '15, 15:44

Open%20Foris's gravatar image

Open Foris ♦♦
2405611
accept rate: 9%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×24

question asked: 27 Oct '15, 10:43

question was seen: 2,791 times

last updated: 20 Apr, 22:45